Join Today
Results 1 to 5 of 5
  1. #1
    Senior Member
    This user has no status
    SaffronC70's Avatar
    Join Date
    Nov 2004
    Location
    Heathrow Area
    Posts
    788
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Idle problem - again !

    Hi guys

    Had the throttle module replaced about 5k miles ago, however the idle has become inconsistant again

    It's ok after a hard run (must be due to moving the throttle plate WOT) but crawling around and after parking manouveurs (spelling?!) the idle will hunt +/- 200 rpm.

    Can I clean this out myself with a little hassle ? Can I idle the car without the boost hosing attached (so I can spray cleaner in) ?

    Thanks

    Chris
    Merc 190E 2.0 Auto

  2. #2
    Senior Member
    This user has no status
    SaffronC70's Avatar
    Join Date
    Nov 2004
    Location
    Heathrow Area
    Posts
    788
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for the input :p

    To try and cure the idle, I sprayed in some Intake Cleaner through the aperture where a sensor usually sits, looks like a pressure sensor, at idle (this is on the plastic pipe that connects to the throttle housing after intercooler piping).

    This made the idle solid again

    Took it out for a run and everything was good - however, I let it sit for a few minutes to let the turbo cool down, turned it off, back on again and once again the idle hunts

    Does anyone know what I have to clean inside the throttle housing ? Or do I once again have to go back to the specialist ?

    Thanks

    Chris
    Merc 190E 2.0 Auto

  3. #3
    Senior Member
    This user has no status
    SaffronC70's Avatar
    Join Date
    Nov 2004
    Location
    Heathrow Area
    Posts
    788
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Right, I took it one step further.

    I removed the intake pipe and cleaned the inside, as best I could, the butterfly :



    Also, can anyone identify what hould be on the end of the circled outlet ?!



    I'm thinking it may of had a rubber cover on it ? But the recent boosting to 1.2bar all the time may have blown it off ?!

    Thanks

    Chris
    Merc 190E 2.0 Auto

  4. #4
    Senior Member
    This user has no status
    SaffronC70's Avatar
    Join Date
    Nov 2004
    Location
    Heathrow Area
    Posts
    788
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Sod's Law = idle was good today !

    Can someone comment on the circled outlet please ?

    Cheers

    Chris
    Merc 190E 2.0 Auto

  5. #5
    Senior Member
    This user has no status
    SaffronC70's Avatar
    Join Date
    Nov 2004
    Location
    Heathrow Area
    Posts
    788
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Circled outlet is meant to be blanked off.



    Quick vid of throttle plate action (commentry by nosey neighbour).

    http://chriswhiteuk.pwp.blueyonder.co.uk/ets.MPG
    Merc 190E 2.0 Auto


 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
ipv6 ready