Join Today
Results 1 to 7 of 7
  1. #1
    Junior Member
    This user has no status

    Join Date
    Feb 2018
    Location
    Oxfordshire
    Posts
    4
    Thanks
    0
    Thanked 2 Times in 2 Posts

    XC90 loss of power

    Hi all,driving my XC90 d5 (185) 07 plate,all was well,when I restarted the car the engine system service message came on and total lack of power,put my mates snap on code reader in and said it was boost pressure sensor and atmospheric pressure sensor,it does sound possible but also told only Vida/dice can read it correctly ,I did clean egr valve and pipes but no change,anybody else had these problems,many thanks

  2. #2
    Gearbox Killer
    Proving the power of the
    15g....13.4@104.3mph
    MoleT-5R's Avatar
    Join Date
    Jun 2011
    Location
    Mid-Wales
    Posts
    5,337
    Thanks
    2,734
    Thanked 2,564 Times in 1,715 Posts
    Have you checked all the hoses for boost leaks, split hoses seem quite common at that age from what I'm seeing lately.

    Current Volvo's 1995 854 Gul T-5R 1996 855 Olive T-5R 1997 855 Olive AWD 1999 V70R AWD and 2005 XC90 D5 AWD
    Previous Volvo's 1987 745 gle 1989 745 GL 1995 855 Olive GLE 2001 V70 p2
    My Ebay Items http://www.ebay.co.uk/usr/quik.connection

  3. #3
    Junior Member
    This user has no status

    Join Date
    Feb 2018
    Location
    Oxfordshire
    Posts
    4
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Hi,checked hoses for leaks,nothing obvious,seems to be the turbo not working so wondering if it’s the turbo actuator,been told they can give problems I have ordered a new boost pressure sensor,I’ll try that if that doesn’t work we have a Volvo indie not to far away so maybe see what he says, thanks for your ideas,I will have another look tomorrow,cheers

  4. The Following User Says Thank You to Volvocol For This Useful Post:

    MoleT-5R (Monday 20th January 2020)

  5. #4
    Senior Member
    Appreciative
    kmb's Avatar
    Join Date
    Oct 2014
    Location
    Suffolk & Rhone Alpes
    Posts
    1,292
    Thanks
    777
    Thanked 431 Times in 352 Posts
    Keep us posted how you get on, hopefully it'll be quickly sorted without much cost.

  6. #5
    Junior Member
    This user has no status

    Join Date
    Feb 2018
    Location
    Oxfordshire
    Posts
    4
    Thanks
    0
    Thanked 2 Times in 2 Posts
    I will,fingers crossed it won’t cost me a fortune,worse thing is not being sure of what the exact fault is,never liked fault Code’s,also have a 99 v70r awd ,thankfully that never let’s me down,cheers

  7. #6
    Junior Member
    This user has no status

    Join Date
    Feb 2018
    Location
    Oxfordshire
    Posts
    4
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Hi,changed the boost pressure sensor and removed engine management light,started fine drove a couple of miles and seems ok,back to full power,it still has the engine system service message on the dash so maybe there’s another problem?,doing a longer drive at the weekend so I’ll have to see how it goes,cheers

  8. The Following User Says Thank You to Volvocol For This Useful Post:

    kmb (Tuesday 21st January 2020)

  9. #7
    SpongeBob Foamypants
    Back in a V70 and happy!!
    foammanmark's Avatar
    Join Date
    Nov 2011
    Location
    Nowhere near Blackburn.....
    Posts
    7,622
    Thanks
    1,589
    Thanked 1,444 Times in 1,268 Posts
    I have something similar with my V70 D5(185). Engine sounds normal but no power and EML on.
    My car is waiting to go into the garage, but they think that from what I have told them that it is an intercooler pipe that runs under the engine, loose or split. My V70 2.4D had exactly the same issue and they are known for it apparently.

    I hope that's all it is but I shall find out soon. I'm tempted just to jack the thing up and get the undertray off to see what I can see.


 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
ipv6 ready