Join Today
Results 1 to 3 of 3

Thread: Throttle body ?

  1. #1
    Junior Member
    This user has no status

    Join Date
    Dec 2018
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Throttle body ?

    Hi everyone, just a quickie if I may ? .. Im having starting issues with my 2012 V50 2.0 D3. Iv read quite a lot about throttle bodies causing issues so iv decided to remove for a clean and inspection. Problem is what Haynes describes as the throttle body doesn't match up to what im seeing online ? They all seem to have a plastic housing were mine is metal ? Am I on the wrong part here ?

    Any help ( as I am a bit special ) would be greatly appreciated

    Name:  TB.jpg
Views: 0
Size:  56.0 KB

  2. #2
    Senior Member
    This user has no status

    Join Date
    Aug 2008
    Location
    Lockerbie, SW Scotland
    Posts
    516
    Thanks
    2
    Thanked 76 Times in 64 Posts
    I could be wrong but I think alot of the starting issues were with the plastic throttle bodies on the PSA 2.0 D (4 cylinder) engines found across the earlier V50/S40 cars.
    08' V50 D5 R Design
    09' V70 2.0D R Design
    My investment: - 96' 850R estate manual

  3. #3
    Senior Member
    Trying to keep on top of it
    LeeT5's Avatar
    Join Date
    Oct 2004
    Location
    Kent
    Posts
    5,108
    Thanks
    989
    Thanked 1,331 Times in 1,018 Posts
    Quote Originally Posted by ChrisR9976 View Post
    Hi everyone, just a quickie if I may ? .. Im having starting issues with my 2012 V50 2.0 D3. Iv read quite a lot about throttle bodies causing issues so iv decided to remove for a clean and inspection. Problem is what Haynes describes as the throttle body doesn't match up to what im seeing online ? They all seem to have a plastic housing were mine is metal ? Am I on the wrong part here ?

    Any help ( as I am a bit special ) would be greatly appreciated

    Name:  TB.jpg
Views: 0
Size:  56.0 KB
    First things first.....Pick up your Haynes book of lies and throw it in the bin! You don't need it anyway, it'll only confuse you and lead you up the garden path.

    Secondly, yes, that is your ETM (Electronic Throttle Module) or throttle assembly/throttle body (whatever floats your boat). It looks like a Magnetti Marelli unit?

    Thirdly (I know it's a diesel) but that is absolutely minging mate!!!

    Get an old toothbrush and a can of Carburettor cleaner and give the entire thing a good scrub. Do not submerge it in any solvents/petrol as you'll kill it!

    Then you'll need to refit and reset the throttle adaptions using VIDA or some other good quality diagnostic tool.

    Then reap the rewards!

    If that does not solve your starting issue, then it's more likely your EGR valve, which judging by the state of your ETM will be in a much worse state!

    2004 V70R 6spd manual:: Custom JRtuning REMAP @ peak 21psi :: Custom 2.75" exhaust :: TTV SMF + 07 Clutch :: WG 5.0 psi :: Tints :: IPD R gauge Rev.3 :: CFWerks door pod :: Forge CBV + yellow spring :: Windowed stock housing + blue filter :: Powerflex :: Superpro Engine mount :: Brembo Dot 5.1 :: TW FMIC :: Eibach 5mm spacers :: Brembo 330mm drilled discs :: iMiV 'Classic'+ BT :: D2R XENARC 5500k + LED H7 + LED H3 :: VolvoTech CFE OBD-V1 :: See garage for full mod list


 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
ipv6 ready