Join Today
Results 1 to 3 of 3
  1. #1
    Junior Member
    This user has no status

    Join Date
    Mar 2018
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Strange sucking noise?

    Hoping somebody can help me out. 

    Just been to view a V70 D5 2007 185bhp (P2) and i was really happy with it apart from one area of concern.

    When out driving, under load from about 1500rpm there was a distictive grainy/sucking noise coming from (i assume) the engine bay, but it the noise sounded like it was coming through in dials/instrument panel.

    Once stationary with the bonnet up, you couldn't hear it when revving the engine, only when actually driving.

    There was another V70 with identical engine on-site so we took that out for a test drive and it did not make the noise. We also took the dealer/seller out for a quick drive to show him (as he said he drives a D5 V70 as well and i wondered if it might have been normal noise), but he said he couldn't hear it, which is wierd because it's very noticeable. 

    Anyone got any ideas what it could be? I liked everything else about the car and have been searching for ages. 

    Cheers.

  2. #2
    Senior Member
    No poke with out smoke
    S40kieran's Avatar
    Join Date
    Feb 2015
    Location
    Paignton/sunny devon
    Posts
    687
    Thanks
    1,444
    Thanked 483 Times in 338 Posts
    Could be several things first thing I would check is the vacuum mounts and turbo hoses, did you take off the oil filler cap if that is making a loud popping sound and then disappears somewhat when you pinch the vacuum hoses leading to the two mounts you know that's you're issue. Easy enough fix.
    Two volvo Kieran, volvo s40 1.9d and volvo s60 d5 remapped by polestar.

  3. #3
    Senior Member
    No poke with out smoke
    S40kieran's Avatar
    Join Date
    Feb 2015
    Location
    Paignton/sunny devon
    Posts
    687
    Thanks
    1,444
    Thanked 483 Times in 338 Posts
    Also junior check the air filter box when i first bought mine it sounded very inductiony turned out previous owner had put a k an n filter in it. Also currently one of my mounts is on the way out it car sounds like a tug boat at times, but because of all this crap weather I haven't been able to get the mount in and fix. I hardly drive it so not an issue at moment
    Two volvo Kieran, volvo s40 1.9d and volvo s60 d5 remapped by polestar.


 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
ipv6 ready