Join Today
Results 1 to 12 of 12
  1. #1
    Senior Member
    This user has no status
    jez.w's Avatar
    Join Date
    Sep 2008
    Location
    Bedfordshire
    Posts
    371
    Thanks
    49
    Thanked 53 Times in 46 Posts

    C70 2.4t running rough

    Hello,

    Had my c70 for while now and i have replaced several items as well as servicing the car myself. It is a 2.4t me7 engine. I fitted a new bosch front lambda sensor a while ago and also i fitted a full pvc system as mine was perished and leaking oil. When i got the car about 9 months ago i had the etm repaired which i refitted and then had a new cambelt kit and water pump fitted and 5 new coil packs, plugs, and volvo bcs then car was checked over and remapped by hlm. Everything has been good except for a very occasional hesitation but not bad and rarely. Car has been pulling well for months.

    Anyway now my car has started to drive badly and holds back and hesistates all the time above 3000 rpm. It starts and idles fine but is playing up unless i drive very gently. I'm sure i have a boost or vac leak some where but i have taken off all the pipes i can and cannot find any problems. The pvc is perfect with no leaks, i have taken off the corrigated boost pipe from MAF to turbo and etm to intercooler pipe which is all good. Also i have checked the vac pipes from the bcs to turbo and they are all good. As a precaution i took the plate off the turbo and checked the recirc valve and that is perfect too. The intercooler looks good to me too.

    I have scanned the codes and i have no dtc codes.

    I'm thinking the bosch MAF sensor could be dodgy as its never been changed as has 1999 date on it. I have a live data scanner so i could test the MAF but i have no idea what the range of readings on the scanner should be.

    Does anyone know what the range should be on the live data scan for a good MAF for my car? I can find various ranges on the internet.

    If no joy I'm happy to take it to a Volvo tuner to be diagnosed as i don't want to guess and fit parts i don't need. I'm based in Herts/Beds border near Hitchen so HLM is a longish way for me and requires a day off work, but i am happy to go back there. Is there anywhere else near to me or is hlm still the nearest best place for me. I don't want to go to a stealer as i will loose my remap as they have told me they update all software and go from there...

    Cheer
    Jez

    C70 2.4T Manual

  2. #2
    Senior Member
    This user has no status
    deathrider311271's Avatar
    Join Date
    Apr 2011
    Location
    Grimsby
    Posts
    1,571
    Thanks
    470
    Thanked 526 Times in 419 Posts
    easy test, unplug the maf sensor take it for a run and see if it runs better. The throttle will be like an on off switch and your fan will run constantly as well as chuck up the engine light.

    But as you have a scanner you can clear the light anyway.
    P1 V70 2.5T Scorpion Exhaust, 3" downpipe 100cel cat, BSR induction, KKK24, GWE 3" Maf to turbo pipe,japanifold , 2010 V50 T5 Alloys Projector Headlamps with 5k Hid kit Quickshift kit, strut brace, Koni Yellow Sport,IPD BCS AET motorsport remap
    Previous: 2004 XC90 T6, 240GLT Estate, 343DL
    Toys: Capri 3.7 Twin turbo, Kawasaki ZX10R 2006,

  3. #3
    Senior Member
    This user has no status
    jez.w's Avatar
    Join Date
    Sep 2008
    Location
    Bedfordshire
    Posts
    371
    Thanks
    49
    Thanked 53 Times in 46 Posts
    Done this, it runs terrible and the revs keep dropping.

    So its worse if i unplug the MAF.

    Think i need to take it to Volvo specialist as its hard to diagnose without fault codes and i cant find any air leaks, but is there one nearer to me than HLM? I'm based near Hitchin in herts and as i said HLM is a pain to get to and requires a day of work for me.

    Cheers
    Jez

    C70 2.4T Manual

  4. #4
    Member
    This user has no status

    Join Date
    Oct 2013
    Location
    Blackpool
    Posts
    81
    Thanks
    1
    Thanked 58 Times in 42 Posts
    What make of plugs did you fit to it, these cars can be rather "Picky" when it comes to spark plugs - Mike

  5. #5
    Senior Member
    This user has no status
    jez.w's Avatar
    Join Date
    Sep 2008
    Location
    Bedfordshire
    Posts
    371
    Thanks
    49
    Thanked 53 Times in 46 Posts
    Standard Volvo ones for my car. Everything on the car as-is was ok, just started playing up recently. I havent changed or fiddled with anything to cause it if you know what i mean. I have a feeling it will need to go to a specialist to fix.
    Jez

    C70 2.4T Manual

  6. #6
    Senior Member
    "Need More Power
    Captain"
    c70geoff's Avatar
    Join Date
    Jul 2012
    Location
    Pontypool, South Wales
    Posts
    1,201
    Thanks
    651
    Thanked 384 Times in 265 Posts
    Try removing the etm and giving that a good clean out fella
    C70 2.4 T Saffy Pearl now dead and stripped
    850 T5 "the Turk" wagon
    V70 D5 parked up for sale
    V50 1.8s family wagon

  7. #7
    Senior Member
    This user has no status
    jez.w's Avatar
    Join Date
    Sep 2008
    Location
    Bedfordshire
    Posts
    371
    Thanks
    49
    Thanked 53 Times in 46 Posts
    ETM is clean and was repaired around 9 months ago to a contactless type. I took etm off again and checked a month or so ago as i thought this could be the problem but it made no difference, it was still clean and i used a new gasket when i put it back on.

    Its going to have to go to a specialist next time i get a spare day
    Jez

    C70 2.4T Manual

  8. #8
    Senior Member
    This user has no status
    jez.w's Avatar
    Join Date
    Sep 2008
    Location
    Bedfordshire
    Posts
    371
    Thanks
    49
    Thanked 53 Times in 46 Posts
    Right got an update. Starting driving really bad now, worse than ever. And today at last the CEL light came on for the first time. I plugged in my scanner and code is P0013 camshaft position or actuator exhaust. Also i noticed that the car cranked over for a long time before it would start the last few days. So my feeling is it is the camshaft position sensor as it is not unusual for this to go on a car of this age.

    But before i order a 120 camshaft sensor has anyone got any other ideas or things to check before i do?

    Cheers in advance!
    Jez

    C70 2.4T Manual

  9. #9
    Senior Member
    Southern AA patrol.
    AAnickmac's Avatar
    Join Date
    Aug 2013
    Location
    West sussex
    Posts
    183
    Thanks
    63
    Thanked 61 Times in 52 Posts
    I would still get it plugged in some where. Have a look at live readings in the ecu. See if you are dropping the signal from cam or crankshaft sensor. If you have AA or RAC cover call them out and they can read all the codes and live readings. May help.

  10. #10
    Senior Member
    Keeping it looking stock
    Harvey's Avatar
    Join Date
    Mar 2012
    Location
    Newton abbot, Devon
    Posts
    5,432
    Thanks
    871
    Thanked 1,514 Times in 1,245 Posts
    Have you changed the fuel filter yet.sounds like a fuel supply/pressure if it's ok if you drive it gently ?.

    Also will get strange readings from the exhaust sensors as it will try to compensate if it's running lean.
    Last edited by Harvey; Monday 11th November 2013 at 10:16.

  11. #11
    Senior Member
    This user has no status
    jez.w's Avatar
    Join Date
    Sep 2008
    Location
    Bedfordshire
    Posts
    371
    Thanks
    49
    Thanked 53 Times in 46 Posts
    Still running bad and holding back most of the time. Cant stand it any longer.... going to have to take a day off work and take it to HLM. I will report back what they find.
    Jez

    C70 2.4T Manual

  12. #12
    Trader
    ???
    merc85's Avatar
    Join Date
    Sep 2010
    Location
    Harwich Essex
    Posts
    7,845
    Thanks
    4,977
    Thanked 2,860 Times in 2,154 Posts
    You have pm


 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
ipv6 ready