Join Today
Results 1 to 17 of 17
  1. #1
    Member
    This user has no status

    Join Date
    Jul 2013
    Location
    Haarlem, Netherlands
    Posts
    55
    Thanks
    0
    Thanked 5 Times in 5 Posts

    2002 s60 T5 and overboosting.

    Hi All,

    Had a re flash done by a known tuner in Belgium. After the re flash we took a test drive, several WOT to measure and the car would pull decently, boost to 1.3 bar and then hold steady at 1.2 bar, lambda value of 0.97... all clean.

    Later that day the boost became harsher and harder at part open throttle and the boost started to flutter like on -off on- off...... I got a warning triangle and the message: engine programming service required. I can drive the car but have to be carefull on the throttle because boost will kick in hard and will start to flutter (I am assuming over boost). Since we programmed at a fairly safe 1.2 bar (17.4 Psi) boost.... what could have happened? Is this some kind of adaptive behavior of the ME7?

    The car has new boost control valve, new MAF, plugs and ignition coils, no obvious airleaks and a clean etm... air and fuel filter are new and clean.
    Thanks for any tip,

    Marc

  2. #2
    Driving Miss Daisy
    This user has no status
    V70 Graham's Avatar
    Join Date
    Feb 2012
    Location
    West London
    Posts
    10,942
    Thanks
    2,909
    Thanked 4,171 Times in 2,943 Posts
    Quote Originally Posted by Marc Lenssen View Post
    Thanks for any tip,

    Marc
    Tip No 1 : Get yourself over here.....http://www.vpcuk.org/forums/forumdis...oduce-Yourself to say hello, we're not a bad lot really, maybe even post up some pictures of your car. I'm sure there will be more knowledgeable people along shortly to answer your query.


    The Relentless Pursuit Of Perfection

  3. #3
    Senior Member
    228k and still not broke it!

    Join Date
    Jul 2011
    Location
    Poole, Dorset
    Posts
    23,116
    Thanks
    6,499
    Thanked 7,717 Times in 5,627 Posts
    my ME7 boosts to 16-20 psi with a standard map and a bleed valve with no errors at all. I guess there's something else wrong.
    19t, greens, 3" inlet, 3" downpipe with race cat, V70R catback, autotech map...

    310.2bhp / 333ft/lb

    2016 Swedish Day UK "Best Modified Swede"

  4. #4
    Member
    This user has no status

    Join Date
    Jul 2013
    Location
    Haarlem, Netherlands
    Posts
    55
    Thanks
    0
    Thanked 5 Times in 5 Posts
    Hello MRP,

    Car boosted 19 psi at WOT right after the re flash. It was only about a 70 miles of interior roads and freeway driving that the boost became erratic. I first noticed a hard boost when pulling from low rpm toddling along at 2000 rpm in 5th. I gave part throttle and the sudden and strong boost surprised me...then the boost would drop and go back on in quick order...stuttering... Earlier I had the idea that the boost would come in as normal and then a sudden kick in boost came on...no fluttering though. Then I tried other gears once off the freeway and the boost was much stronger then when we tested after re map and the stutter could eaily be provoked at part throttle.... I didn't even dare full throttle anymore... But since the tune was supposed to be fairly tame and actually was tame when we test drove the later behavior surprised me and I wonder what can cause it. Error message is engine management service required....

  5. #5
    Senior Member
    This user has no status

    Join Date
    Jul 2008
    Posts
    846
    Thanks
    126
    Thanked 177 Times in 140 Posts
    Err is that not a bit lean for that boost?

    Check the hose on the compressor, it sounds like it's off or split.

  6. #6
    Senior Member
    228k and still not broke it!

    Join Date
    Jul 2011
    Location
    Poole, Dorset
    Posts
    23,116
    Thanks
    6,499
    Thanked 7,717 Times in 5,627 Posts
    have you had the throttle module replaced/repaired at all? being 2002, it'll have the magmetti marelli throttle which can fail and cause no end of problems.
    19t, greens, 3" inlet, 3" downpipe with race cat, V70R catback, autotech map...

    310.2bhp / 333ft/lb

    2016 Swedish Day UK "Best Modified Swede"

  7. #7
    Member
    This user has no status

    Join Date
    Jul 2013
    Location
    Haarlem, Netherlands
    Posts
    55
    Thanks
    0
    Thanked 5 Times in 5 Posts
    2002 is the Bosch ETM, had it cleaned recently, no idle issues and no throttle issues. This over boosting started after the remap, all hoses checked and none split, most replaced by new or silicone ones and no boosting issues up until the remap. \The thing I don't get is that the test rides directly after the remap worked fine, good boost and held boost at WOT, CEL and no issues whatsoever. An hours driving after the test runs the boost started to act up and the CEL came on. No hardware changed in the mean time, that is why I wondered if the ME7 might mess up a re map because of its adaptive nature. I don't know if a 0.98 Lambda value at WOT is lean for this boost, this is what the tuner measured during the test drive. According to him it was a safe value.
    Marc

  8. #8
    Senior Member
    228k and still not broke it!

    Join Date
    Jul 2011
    Location
    Poole, Dorset
    Posts
    23,116
    Thanks
    6,499
    Thanked 7,717 Times in 5,627 Posts
    hmmm, perhaps there's a lambda fault giving the ecu inconsistent or incorrect readings. this could potentially cause WOT problems. loads of ME7 cars are mapped without any adaptation issues at all.
    19t, greens, 3" inlet, 3" downpipe with race cat, V70R catback, autotech map...

    310.2bhp / 333ft/lb

    2016 Swedish Day UK "Best Modified Swede"

  9. #9
    Senior Member
    Still more fettling needed,
    will it never end?
    stribo's Avatar
    Join Date
    Jan 2012
    Location
    Mortimer
    Posts
    13,276
    Thanks
    2,610
    Thanked 4,556 Times in 3,379 Posts
    Who in their right mind would have an ME7

  10. #10
    Senior Member
    This user has no status

    Join Date
    Jul 2011
    Location
    wallasey
    Posts
    372
    Thanks
    19
    Thanked 69 Times in 62 Posts
    read the codes first ,find out what dtcs has popped up then work from there otherwise its guess work .did your remap include a rear lambda delete if not then I would suggest you use a spacer on the rear lambda. I have a s60t5 with the same light on the dash came on 3 days after remap ,after reading codes I found ecm-4801 . turns out it was the rear lambda needs a spacer to remove it from the flow .

  11. #11
    Senior Member
    This user has no status

    Join Date
    Jul 2011
    Location
    wallasey
    Posts
    372
    Thanks
    19
    Thanked 69 Times in 62 Posts
    i had a rica remap before this map and i had no rear lambda problems i think rica must delete the sensor .

  12. #12
    Driving Miss Daisy
    This user has no status
    V70 Graham's Avatar
    Join Date
    Feb 2012
    Location
    West London
    Posts
    10,942
    Thanks
    2,909
    Thanked 4,171 Times in 2,943 Posts
    Quote Originally Posted by stribo View Post
    Who in their right mind would have an ME7
    Er.....


    The Relentless Pursuit Of Perfection

  13. #13
    Senior Member
    228k and still not broke it!

    Join Date
    Jul 2011
    Location
    Poole, Dorset
    Posts
    23,116
    Thanks
    6,499
    Thanked 7,717 Times in 5,627 Posts
    Quote Originally Posted by stribo View Post
    Who in their right mind would have an ME7
    our wives.
    19t, greens, 3" inlet, 3" downpipe with race cat, V70R catback, autotech map...

    310.2bhp / 333ft/lb

    2016 Swedish Day UK "Best Modified Swede"

  14. #14
    Member
    This user has no status

    Join Date
    Jul 2013
    Location
    Haarlem, Netherlands
    Posts
    55
    Thanks
    0
    Thanked 5 Times in 5 Posts
    :-)

    I am going back to the tuner tonight. we will read codes and re look at the mapping itself. No issue there, I just wanted to get some pointers on what to look for. Ill ask about the rear lambda. The front lambda is original at 204.000 kilometers but is ordered (Bosch part) and should arrive shortly. But the lambda did not seem to give any issues before. '
    ME7 car is a fine motor for cruising, nice and quiet but it indeed lacks the directness and grunt of the earlier ones, had a Rica'd S70 t5 before and before that an 850 t5 with a manual boost controller...both giving immediate and raw power when punched.... wheel spin in all gears. But those ones you tune on boost levels, the ME7 is mapped on max allowable torque for any given throttle pos and rpm.. then it is up to ME7 to figure out how much boost it needs to produce that torque...
    So I'll ask the tuner about error codes and the rear lambda (if it is on or off). And adjust from there.
    Thanks guys, I have been lazy and not posted any pics (don't have ones yet....just have the car a few weeks and been too busy doing suspension and engine stage 0) and then report back on the second attempt.. :-)
    Marc

  15. #15
    Senior Member
    228k and still not broke it!

    Join Date
    Jul 2011
    Location
    Poole, Dorset
    Posts
    23,116
    Thanks
    6,499
    Thanked 7,717 Times in 5,627 Posts
    Keep us posted mate
    19t, greens, 3" inlet, 3" downpipe with race cat, V70R catback, autotech map...

    310.2bhp / 333ft/lb

    2016 Swedish Day UK "Best Modified Swede"

  16. #16
    Member
    This user has no status

    Join Date
    Jul 2013
    Location
    Haarlem, Netherlands
    Posts
    55
    Thanks
    0
    Thanked 5 Times in 5 Posts
    Ok, back from a session with the tuner... it wasn't over boosting it was wastegate flutter, not easy to tune in the ME7 computers.
    After tuning down some setting for the waste gate management in about 7 steps (and test drives) most of it is gone. Only at very light throttle opening do I still feel some flutter. But both him and me were running out of time and patience to continue. Car is boosting nicely now, nice strong pull at 1/3 throttle.... I'll drive it for 1-2 weeks and see if something settles or if I go back for a last round....
    So far so good... tuner is a small Belgium outfit called Medusa motorsports... and he came recommended highly on the Dutch 850 forum where there are plenty ME7 S-V 70's.
    And best of all, 3 hours of work including fine tuning for 212 pounds.... :-)

  17. #17
    Senior Member
    Still more fettling needed,
    will it never end?
    stribo's Avatar
    Join Date
    Jan 2012
    Location
    Mortimer
    Posts
    13,276
    Thanks
    2,610
    Thanked 4,556 Times in 3,379 Posts
    Quote Originally Posted by M-R-P View Post
    our wives.
    My wife hasn't


 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
ipv6 ready