Join Today
Results 1 to 19 of 19
  1. #1
    Senior Member
    This user has no status
    simpT5's Avatar
    Join Date
    Jan 2009
    Location
    cheshire
    Posts
    159
    Thanks
    63
    Thanked 38 Times in 32 Posts

    Powerflex Top Engine mount

    My top engine mount bush is split so after reading some posts on this forum I have decided to replace it with a poly bush from powerflex, however, I can't seem to figure out if I need the purple or yellow bush? My car is a 1999 V70 p1 T5 with the me7/fly by wire throttle setup.

    Can anyone please confirm which one I need to order, and if so where from?

    Thanks,
    simpT5

  2. #2
    Senior Member
    This user has no status

    Join Date
    Jul 2008
    Posts
    6,300
    Thanks
    2,869
    Thanked 2,643 Times in 1,928 Posts
    Not sure about the ME7 model but the cable 70's should have purple bushes.


    Gun Metal Grey - Volvo 850R - Saloon
    Thanks to Russ and team www.rtmechanics.co.uk

  3. #3
    Senior Member
    This user has no status

    Join Date
    May 2005
    Location
    Chester, UK
    Posts
    809
    Thanks
    98
    Thanked 72 Times in 69 Posts
    Yellow aint it.....pretty sure it was Yellow

    Just like This one

  4. #4
    Senior Member
    This user has no status

    Join Date
    Jul 2008
    Posts
    636
    Thanks
    38
    Thanked 113 Times in 101 Posts
    If the engine mount is an aluminium block, then it requires a yellow one.

  5. #5
    Senior Member
    This user has no status
    Happygilmore78's Avatar
    Join Date
    Jan 2009
    Location
    Preston, Lancashire
    Posts
    1,261
    Thanks
    367
    Thanked 241 Times in 184 Posts
    I have a purple one in my 2000 c70, but to be honest, it feels wrong, only because all the 'how to do its' made it look like hard work getting it in, but mine just slid in really easy like butter??
    I created a genius, who outgrew my teachings, and is now being mentored by a new sensei! Live long Victor!

  6. #6
    Senior Member
    This user has no status

    Join Date
    Jul 2008
    Posts
    636
    Thanks
    38
    Thanked 113 Times in 101 Posts
    Quote Originally Posted by Happygilmore78 View Post
    I have a purple one in my 2000 c70, but to be honest, it feels wrong, only because all the 'how to do its' made it look like hard work getting it in, but mine just slid in really easy like butter??
    You've got the wrong one fitted I suspect, however, fitting the yellow one to the alu mount is just a push in job, not like getting the purple bush into the older style mount

    Black metal "cage-like" mount = purple bush
    Solid aluminium block mount = yellow bush

  7. The Following User Says Thank You to Wombatbomb For This Useful Post:

    simpT5 (Wednesday 21st January 2009)

  8. #7
    Senior Member
    This user has no status
    Happygilmore78's Avatar
    Join Date
    Jan 2009
    Location
    Preston, Lancashire
    Posts
    1,261
    Thanks
    367
    Thanked 241 Times in 184 Posts
    Ah, he sold it as my year - i dont have receipt or anything now - oh well, looks like i'm buying another.

    Anyone need a purple one when i get this new yellow mount?
    I created a genius, who outgrew my teachings, and is now being mentored by a new sensei! Live long Victor!

  9. #8
    Senior Member
    This user has no status
    simpT5's Avatar
    Join Date
    Jan 2009
    Location
    cheshire
    Posts
    159
    Thanks
    63
    Thanked 38 Times in 32 Posts
    Thanks alot for your replys, ive just been and had a look at mine and its a solid aluminium block so I need a yellow bush!

    I noticed the link to parts for volvos online is an American based company. Has anyone any positive experiences ordering from them? I could do with one asap and don't fancy waiting weeks for one to come!

  10. #9
    Shiny Superstar
    Back in the game!
    Wobbly Dave's Avatar
    Join Date
    Aug 2004
    Location
    Stunning Shropshire
    Posts
    17,736
    Thanks
    2,495
    Thanked 3,456 Times in 2,451 Posts
    you can buy the upgraded Volvo OEM top engine mount. It consists of a cruciform rubber block that can never split.

    Also you dont get the increased engine noise through the bulkhead associated with poly bushes. I think the mount is about 30 quid or so.
    Attached Images Attached Images  
    Last edited by Wobbly Dave; Wednesday 21st January 2009 at 11:21.
    Volvo ABS ECU Repair
    Join my projecteers tribe - Old Volvos Never Die - They just get faster.

    Visit my VPCUK garage and my YouTube channel - WobblyDave72

  11. #10
    Senior Member
    This user has no status

    Join Date
    Jul 2008
    Posts
    636
    Thanks
    38
    Thanked 113 Times in 101 Posts
    Quote Originally Posted by simpT5 View Post
    Thanks alot for your replys, ive just been and had a look at mine and its a solid aluminium block so I need a yellow bush!

    I noticed the link to parts for volvos online is an American based company. Has anyone any positive experiences ordering from them? I could do with one asap and don't fancy waiting weeks for one to come!
    Huh????? PFV is a UK company.

  12. #11
    Senior Member
    This user has no status
    Happygilmore78's Avatar
    Join Date
    Jan 2009
    Location
    Preston, Lancashire
    Posts
    1,261
    Thanks
    367
    Thanked 241 Times in 184 Posts
    I have bought off them and they were good mate
    I created a genius, who outgrew my teachings, and is now being mentored by a new sensei! Live long Victor!

  13. #12
    Senior Member
    This user has no status
    simpT5's Avatar
    Join Date
    Jan 2009
    Location
    cheshire
    Posts
    159
    Thanks
    63
    Thanked 38 Times in 32 Posts
    Quote Originally Posted by Wombatbomb View Post
    Huh????? PFV is a UK company.
    Doh, I saw the $ and put two and two together and assumed they were an American company!

    I have just ordered my yellow poly bush so hopefully it might be here for the weekend, that'll keep me busy for a bit!

    Thanks again to all those who replied, your info is appreciated.

    Cheers,
    SimpT5.

  14. #13
    Trader
    This user has no status
    Rufe's Avatar
    Join Date
    Mar 2005
    Location
    Abertawe, Cymru (Swansea, Wales)
    Posts
    2,014
    Thanks
    227
    Thanked 291 Times in 213 Posts
    The modified genuine (aluminium bracket type) top engine mount that wobbly dave is talking about retail at 43.24 inc vat, though we sell them at 31.57 inc vat, plus 4.20 postage to mainland Uk. The modified version is a much better design as dave says. (modified mount pn is 30680770)

    Simon
    If VOLVO is Your Drug, I am Your Dealer!

    FRF FEEDBACK (click here)



    Click Here for Info on FRF Motors...


    <FOR QUOTES PLEASE CALL 01792 790066 / 01792 784272>

    (Mon to Fri 9am to 5pm)

    PLEASE QUOTE DISCOUNT CODE: "C3" FOR OUR BEST DISCOUNTED PRICES!


  15. The Following User Says Thank You to Rufe For This Useful Post:

    Wobbly Dave (Wednesday 21st January 2009)

  16. #14
    Member
    This user has no status

    Join Date
    Jul 2006
    Posts
    67
    Thanks
    3
    Thanked 4 Times in 2 Posts
    I bought the upgraded OEM part (square block type) and the bloody thing has failed on me.

    What I thought was a split gearbox torque mount, is actually a worn out torque mount with a failed top mount.

    The bush is sliding from side to side in the housing, you can move it by hand!! Are there any ways to repair this or are there any upgraded PU bushes for the square block type mount?

    The old ally housing housed a round mount, which had split - this (I think) has been disposed of. If it hasn't I'll just buy the round PU mount, but I'm loathed to only have got 1yr out of the square one when it's this new upgraded and "better" design

  17. #15
    Senior Member
    This user has no status
    gazbak1's Avatar
    Join Date
    Jul 2008
    Posts
    218
    Thanks
    11
    Thanked 36 Times in 32 Posts
    the new mount is supposed to do that. that is why i fitted a poly bush. yes there was a vibration on idle at first but after a week of driving has settled down and feels like normal with a nice engine note.

    hope this helps

    gazbak1

  18. #16
    Member
    This user has no status

    Join Date
    Jul 2006
    Posts
    67
    Thanks
    3
    Thanked 4 Times in 2 Posts
    the oem mount is meant to be loose in the housing?!?!

    what's the point in having the mount there - the engine rocks and rolls all over the place!

  19. #17
    Senior Member
    This user has no status
    gazbak1's Avatar
    Join Date
    Jul 2008
    Posts
    218
    Thanks
    11
    Thanked 36 Times in 32 Posts
    Quote Originally Posted by BlackC70 View Post
    the oem mount is meant to be loose in the housing?!?!

    what's the point in having the mount there - the engine rocks and rolls all over the place!
    to a point yes, not excessive though

    gazbak1

  20. #18
    Member
    This user has no status

    Join Date
    Jul 2006
    Posts
    67
    Thanks
    3
    Thanked 4 Times in 2 Posts
    I think this one is excessive to the point of ridiculous! I would probably be able to knock it out the mount using just the force of gravity!

  21. #19
    Senior Member
    Trying to keep on top of it
    LeeT5's Avatar
    Join Date
    Oct 2004
    Location
    Kent
    Posts
    5,096
    Thanks
    980
    Thanked 1,327 Times in 1,016 Posts
    Quote Originally Posted by BlackC70 View Post
    I bought the upgraded OEM part (square block type) and the bloody thing has failed on me.

    What I thought was a split gearbox torque mount, is actually a worn out torque mount with a failed top mount.

    The bush is sliding from side to side in the housing, you can move it by hand!! Are there any ways to repair this or are there any upgraded PU bushes for the square block type mount?

    The old ally housing housed a round mount, which had split - this (I think) has been disposed of. If it hasn't I'll just buy the round PU mount, but I'm loathed to only have got 1yr out of the square one when it's this new upgraded and "better" design
    Err...actually the mount is supposed to be tight not loose. If it were loose then it can't do it's job.

    2004 V70R 6spd manual:: Custom JRtuning REMAP @ peak 21psi :: Custom 2.75" exhaust :: TTV SMF + 07 Clutch :: WG 5.0 psi :: Tints :: IPD R gauge Rev.3 :: CFWerks door pod :: Forge CBV + yellow spring :: Windowed stock housing + blue filter :: Powerflex :: Superpro Engine mount :: Brembo Dot 5.1 :: TW FMIC :: Eibach 5mm spacers :: Brembo 330mm drilled discs :: iMiV 'Classic'+ BT :: D2R XENARC 5500k + LED H7 + LED H3 :: VolvoTech CFE OBD-V1 :: See garage for full mod list


 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
ipv6 ready