Join Today
Page 1 of 2 12 LastLast
Results 1 to 20 of 29
  1. #1
    Senior Member
    This user has no status
    Stevie-Boy's Avatar
    Join Date
    Aug 2008
    Location
    Lake District
    Posts
    146
    Thanks
    10
    Thanked 2 Times in 2 Posts

    T4 Had Dodgy Idle Today and Stalled

    Car has been fine up till today and then as I stopped to reverse the car into a driveway earlier, the revs started to dive up and down and then it stalled. It hasn't done that before :-(

    It fired right back up and I took it for a little spin and it hasn't done it again.

    I note in my other thread about the fan issue that the MAF was mentioned and I'm wondering if this might be the cause for both issues here. I had MAF issues with my Primera Turbo and it ran absolutely awful until sorted so I know how much not to underestimate the effects of a MAF!

    Anyone got any comment on that issue?

    Just had to spend 9 quid on a headlight bulb too and noticed today that one of my low profile tyres had 10psi in and is probably slow punctured.

    The honeymoon period is most definately over!!

    1998 S40 T4
    Two Hundred Horses of Swedish Boost Action!!

  2. #2
    Senior Member
    This user has no status
    S70T5Chris's Avatar
    Join Date
    Mar 2005
    Location
    Dull Southampton!
    Posts
    3,056
    Thanks
    1,123
    Thanked 1,841 Times in 1,058 Posts
    Sounds to me like the Air Idle Control Valve. It's a common fault on the earlier T4's. My T4, on accasion, does the exact same thing. You can take the old one off, and clean it carb cleaner. I have done a couple of times on mine, it seems to work for a short period and then the problem returns, so i'm ordering a new one. From volvo they are about 150, there is someone selling them on ebay for less than 40 delivered! Click Here for the link.

    Once I recieve it, i'll let you know if it's any good!
    Factory White 855R : 2.5 Bottom End : Ported & Flowed Cylinder Head : TD04 19T Turbo
    VXR Injectors : ME7 Manifold : TWR Throttle Body : Blackbeast IC : AEM Progressive WI : Ferrita 3" Downpipe
    Milltek Cat-Back : BC BR Coilovers : IPD ARB : AP Racing Brakes : M56 & Gripper LSD

  3. #3
    Senior Member
    This user has no status
    Stevie-Boy's Avatar
    Join Date
    Aug 2008
    Location
    Lake District
    Posts
    146
    Thanks
    10
    Thanked 2 Times in 2 Posts
    Nice one, cheers for that. How often does the issue come back once you clean it up? Should I expect this problem to keep happening from now on until the part is changed?

    EDIT: If it just happens once in a while and does it once then runs fine for a while, it almost sounds fine just to leave it and put up with it for the times that it does happen!
    Last edited by Stevie-Boy; Sunday 17th August 2008 at 16:28.

    1998 S40 T4
    Two Hundred Horses of Swedish Boost Action!!

  4. #4
    Senior Member
    This user has no status
    S70T5Chris's Avatar
    Join Date
    Mar 2005
    Location
    Dull Southampton!
    Posts
    3,056
    Thanks
    1,123
    Thanked 1,841 Times in 1,058 Posts
    The last time my car did it was about a week ago, it hasn't done it since, but I don't do much mileage in it. I think it'll be pretty random to be honest. It's worth whipping it off and cleaning it out (i'm sure there's a How To on VOC somewhere), that may cure the problem.

    Like I said for 40 it's worth taking a punt on the ebay one. I've ordered one already, if it does the job (I see no reason why it won't!), i'll let you know.
    Factory White 855R : 2.5 Bottom End : Ported & Flowed Cylinder Head : TD04 19T Turbo
    VXR Injectors : ME7 Manifold : TWR Throttle Body : Blackbeast IC : AEM Progressive WI : Ferrita 3" Downpipe
    Milltek Cat-Back : BC BR Coilovers : IPD ARB : AP Racing Brakes : M56 & Gripper LSD

  5. #5
    Senior Member
    This user has no status
    S70T5Chris's Avatar
    Join Date
    Mar 2005
    Location
    Dull Southampton!
    Posts
    3,056
    Thanks
    1,123
    Thanked 1,841 Times in 1,058 Posts
    The How to wasn't on VOC, it's on S40Concepts, Click Here
    Factory White 855R : 2.5 Bottom End : Ported & Flowed Cylinder Head : TD04 19T Turbo
    VXR Injectors : ME7 Manifold : TWR Throttle Body : Blackbeast IC : AEM Progressive WI : Ferrita 3" Downpipe
    Milltek Cat-Back : BC BR Coilovers : IPD ARB : AP Racing Brakes : M56 & Gripper LSD

  6. The Following User Says Thank You to S70T5Chris For This Useful Post:

    Stevie-Boy (Sunday 17th August 2008)

  7. #6
    Member
    This user has no status
    Jocksuper7's Avatar
    Join Date
    Oct 2006
    Location
    Basingstoke and Lockerbie
    Posts
    54
    Thanks
    0
    Thanked 1 Time in 1 Post
    do not buy a cheap maf from ebay unless its from a scraper, they are worse than useless, though however give it a clean up, also if its a phase 2 give the map sensors a quick blast and you should be dancing, if it continues there will be a code that should pop up if its a fueling prob or poor spark but cleaning the maf should do the trick, just be carefull, mine was struggling ideling but it was down to the maf, i changed alsorts to no resolve a 4 quid can of carb cleaner was the key
    Last edited by Jocksuper7; Sunday 17th August 2008 at 16:47.

  8. #7
    Senior Member
    This user has no status
    Stevie-Boy's Avatar
    Join Date
    Aug 2008
    Location
    Lake District
    Posts
    146
    Thanks
    10
    Thanked 2 Times in 2 Posts
    Nice one guys, I shall clean both the MAF and the idle air control valve and see if this does it again. If so, I shall replace the valve and eventually the MAF if it continues :-)

    Just my luck that it starts doing this a couple of weeks after I buy it, typical!!

    1998 S40 T4
    Two Hundred Horses of Swedish Boost Action!!

  9. #8
    Senior Member
    CDO Sufferer
    jimka's Avatar
    Join Date
    Mar 2006
    Location
    Southampton
    Posts
    1,144
    Thanks
    152
    Thanked 197 Times in 156 Posts
    Quote Originally Posted by S70T5Chris View Post
    The How to wasn't on VOC, it's on S40Concepts, Click Here
    just to hi-jack - how is the S40?

  10. #9
    Senior Member
    This user has no status
    S70T5Chris's Avatar
    Join Date
    Mar 2005
    Location
    Dull Southampton!
    Posts
    3,056
    Thanks
    1,123
    Thanked 1,841 Times in 1,058 Posts
    Quote Originally Posted by jimka View Post
    just to hi-jack - how is the S40?
    It's reet! Got a couple of things to do on it (Rear wishbone bushes, AICV, and i've ordered a new fuel pressure regulator, as thats the most probable cause of the slow starting issue!) Other than that it's all good. Still derliberating on what to do with the wheels! I'm taking it to trax in a couple of weeks to chuck round silverstone!

    How's your's going, good? I must come and have a look at this amazon of yours!!
    Factory White 855R : 2.5 Bottom End : Ported & Flowed Cylinder Head : TD04 19T Turbo
    VXR Injectors : ME7 Manifold : TWR Throttle Body : Blackbeast IC : AEM Progressive WI : Ferrita 3" Downpipe
    Milltek Cat-Back : BC BR Coilovers : IPD ARB : AP Racing Brakes : M56 & Gripper LSD

  11. #10
    Senior Member
    CDO Sufferer
    jimka's Avatar
    Join Date
    Mar 2006
    Location
    Southampton
    Posts
    1,144
    Thanks
    152
    Thanked 197 Times in 156 Posts
    Quote Originally Posted by S70T5Chris View Post
    It's reet! Got a couple of things to do on it (Rear wishbone bushes, AICV, and i've ordered a new fuel pressure regulator, as thats the most probable cause of the slow starting issue!) Other than that it's all good. Still derliberating on what to do with the wheels! I'm taking it to trax in a couple of weeks to chuck round silverstone!

    How's your's going, good? I must come and have a look at this amazon of yours!!
    dont! - once you see the welding required even you'll run!

    S40 is good - tempted to flog it and get a T5 again... i'll have to do it whilst "she's" not watching though

  12. #11
    Senior Member
    This user has no status
    S70T5Chris's Avatar
    Join Date
    Mar 2005
    Location
    Dull Southampton!
    Posts
    3,056
    Thanks
    1,123
    Thanked 1,841 Times in 1,058 Posts
    This is what arrived from ebay. Looks decent enough. Fitted it this afternoon, the car's running fine. We'll wait and see if the irratic idle issue is resolved now, i'll keep you updated.

    Factory White 855R : 2.5 Bottom End : Ported & Flowed Cylinder Head : TD04 19T Turbo
    VXR Injectors : ME7 Manifold : TWR Throttle Body : Blackbeast IC : AEM Progressive WI : Ferrita 3" Downpipe
    Milltek Cat-Back : BC BR Coilovers : IPD ARB : AP Racing Brakes : M56 & Gripper LSD

  13. #12
    Senior Member
    This user has no status
    Stevie-Boy's Avatar
    Join Date
    Aug 2008
    Location
    Lake District
    Posts
    146
    Thanks
    10
    Thanked 2 Times in 2 Posts
    Nice one cheers ;-)

    Mine hasn't done the dodgy thing since I posted it but there is time yet :-)

    1998 S40 T4
    Two Hundred Horses of Swedish Boost Action!!

  14. #13
    Senior Member
    This user has no status
    Stevie-Boy's Avatar
    Join Date
    Aug 2008
    Location
    Lake District
    Posts
    146
    Thanks
    10
    Thanked 2 Times in 2 Posts
    My car did the thing again yesterday! Revs went a bit micey at idle and then tried to stall. Just before it had done this, I noticed that when coming off the throttle in the higher gears and then accelerating, there was a hesitation. I'm going to do the valve cleaning job later today.

    Is there anything I should look out for when doing it, any difficult bits in the job or fiddly bits or anything that might stop me being able to do it?

    Cheers.

    1998 S40 T4
    Two Hundred Horses of Swedish Boost Action!!

  15. #14
    Senior Member
    This user has no status
    S70T5Chris's Avatar
    Join Date
    Mar 2005
    Location
    Dull Southampton!
    Posts
    3,056
    Thanks
    1,123
    Thanked 1,841 Times in 1,058 Posts
    Quote Originally Posted by Stevie-Boy View Post
    My car did the thing again yesterday! Revs went a bit micey at idle and then tried to stall. Just before it had done this, I noticed that when coming off the throttle in the higher gears and then accelerating, there was a hesitation. I'm going to do the valve cleaning job later today.

    Is there anything I should look out for when doing it, any difficult bits in the job or fiddly bits or anything that might stop me being able to do it?

    Cheers.
    na it's a piece of piss to do.

    So far I haven't had the problem come back since i fitted the new AICV, but I haven't done a huge amount of mileage.
    Factory White 855R : 2.5 Bottom End : Ported & Flowed Cylinder Head : TD04 19T Turbo
    VXR Injectors : ME7 Manifold : TWR Throttle Body : Blackbeast IC : AEM Progressive WI : Ferrita 3" Downpipe
    Milltek Cat-Back : BC BR Coilovers : IPD ARB : AP Racing Brakes : M56 & Gripper LSD

  16. #15
    Senior Member
    This user has no status
    Stevie-Boy's Avatar
    Join Date
    Aug 2008
    Location
    Lake District
    Posts
    146
    Thanks
    10
    Thanked 2 Times in 2 Posts
    As I could have predicted, mine doesn't seem to look like the one in the how to LOL.

    Can anyone confirm that I am removing the right part please?

    On my T4, that cover is not removable with a hex tool, it is part of the cover that goes over the full engine. Underneath that is what I think is the valve but it looks weird as it has like a cylinder barrel type thing screwed to it and the connector is plugged into the barrel bit rather than the area with the two bolts. Is this the right thing?

    1998 S40 T4
    Two Hundred Horses of Swedish Boost Action!!

  17. #16
    Senior Member
    This user has no status
    Stevie-Boy's Avatar
    Join Date
    Aug 2008
    Location
    Lake District
    Posts
    146
    Thanks
    10
    Thanked 2 Times in 2 Posts
    I used my bonce for once and looked at that ebay link from the start of the thread and spotted that they do indeed have a kinda barrel bolted on, sweet and off I go again!

    1998 S40 T4
    Two Hundred Horses of Swedish Boost Action!!

  18. #17
    Senior Member
    This user has no status
    Stevie-Boy's Avatar
    Join Date
    Aug 2008
    Location
    Lake District
    Posts
    146
    Thanks
    10
    Thanked 2 Times in 2 Posts
    Tried and failed! Needed to remove the full engine cover and I have no tools that will remove those bizarre hex bolt things, grrr. My IAC valve is held in place with hex bolts too, why??!!! Why use poxy bolts that nobody can get out, what is wrong with normal bolts that everyone else uses?!

    I hve some allen keys but they won't seem to remove these, so I guess I need to go and buy a set of sockets that end in these weird hex ends. Weird, annoying!!

    1998 S40 T4
    Two Hundred Horses of Swedish Boost Action!!

  19. #18
    Senior Member
    This user has no status
    Filterlab's Avatar
    Join Date
    Jul 2008
    Location
    Long Stratton, Norfolk
    Posts
    2,079
    Thanks
    257
    Thanked 316 Times in 248 Posts
    Actually Torx bolts are exceptionally common in vehicles, they were introduced by Ford many many years ago to increase the torque by area (hence the name) on a bolt.
    ________________________
    Apple Mac help required?
    Need assistance with your iPad, iPod or iPhone?
    Being harassed by the spinning beach ball of death?


    Get in touch with The Mac Doctor now.
    (Covering Norwich and Norfolk)

  20. #19
    Senior Member
    This user has no status
    Stevie-Boy's Avatar
    Join Date
    Aug 2008
    Location
    Lake District
    Posts
    146
    Thanks
    10
    Thanked 2 Times in 2 Posts
    That's cool, I was just irritated at the time that I couldn't get the bolts out! :-)

    I'll buy a set of torx doofers, hopefully including the size I need!

    If someone with a T4 can confirm the size needed to remove the engine cover and the IAC valve, that would be doubly awesome!

    1998 S40 T4
    Two Hundred Horses of Swedish Boost Action!!

  21. #20
    Senior Member
    This user has no status
    Stevie-Boy's Avatar
    Join Date
    Aug 2008
    Location
    Lake District
    Posts
    146
    Thanks
    10
    Thanked 2 Times in 2 Posts
    Gonna go and buy tools to do this job, anyone know the size before I go? Cheers.

    1998 S40 T4
    Two Hundred Horses of Swedish Boost Action!!


 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
ipv6 ready