PDA

View Full Version : Power Loss at high revs



Vegas531
Thursday 10th February 2005, 14:03
Just wondering if anyone has an idea what the problem could be.......

The problem is, in any gear whilst accelerating, once you hit around 4,500rpm the power just completely dies? Change gear, and the revs drop, the power returns.

The car is a 2001 S60 T5.

Any ideas
cheers Andy.

volvotuning
Thursday 10th February 2005, 18:07
What does the diagnostics say? That's always your first port of call.

Adam.

Vegas531
Thursday 10th February 2005, 19:51
The story develops further....

On the way home tonight, the car gave a cough and the reduced performance light message came on.

Luckily this cough happen right outside my local Volvo dealer so I coasted in and asked for help. When I stopped the car sounded like it was running off less than 5-cylinders - rough as a badgers!

According to the stored error messages there were 2 codes

The first relates to the clutch position sensor which explains why the criuse isn't working but more worringly the Throttle Body error code was registered.

The cars booked in to have the Throttle body cleaned before I shell out 300 for a new one.

Could this be also causing the power loss?

cheers
Andy.

volvotuning
Thursday 10th February 2005, 20:22
The cars booked in to have the Throttle body cleaned before I shell out 300 for a new one.

Could this be also causing the power loss?



Yes! Most definately.

Adam.

Vegas531
Friday 11th February 2005, 09:18
Thanks for that. I'll see how the car runs after the service.

Vegas531
Thursday 10th March 2005, 19:15
Yep, a new throttle body unit has solved the day.

Runs like a dream now.

Andy.

SaffronC70
Thursday 10th March 2005, 20:25
Damn Throttle Bodies, Adam, design a better one :P