PDA

View Full Version : Lock Stops.....



Happygilmore78
Monday 16th November 2009, 00:09
Apparantly mine are missing, anyone have a link to some so i could buy - cant find them online.

Also, where to they bolt to? i have never come across anything like this before - but dont know why mine would be missing.

p fandango
Monday 16th November 2009, 01:41
Apparantly mine are missing, anyone have a link to some so i could buy - cant find them online.

Also, where to they bolt to? i have never come across anything like this before - but dont know why mine would be missing.
i'm only on the netbook so can't check at the minute, but i believe they bolt to the wishbone

http://www.ipdusa.com/product.asp?P_ID=4068

Wombatbomb
Monday 16th November 2009, 09:57
Apparantly mine are missing, anyone have a link to some so i could buy - cant find them online.

Also, where to they bolt to? i have never come across anything like this before - but dont know why mine would be missing.

They are attached to the edge of the lower suspension arm with rivets. Make sure you get the blue ones as these are the correct version for the C70, best method is to get them off Rufe.

Happygilmore78
Monday 16th November 2009, 10:43
Thanks guys :) will PM Rufe

Happygilmore78
Monday 16th November 2009, 13:12
Just had a look round, found this post with some pics to aid me http://www.vpcuk.org/forums/showthread.php?t=17329&highlight=lower+suspension+arm

Missis is ordering them for me today off Simon, so hopefully get them fitted at weekend :)